Screen Spanning Doctor e Leopard 10.5.2 (update)

Dopo l’aggiornamento catastrofico dell’altro giorno, ho deciso di lasciare un po’ tranquillo il mio iBook, fino a stamattina. Stamattina decido che mi serve il monitor esterno, che mi serve in modalità scrivania estesa e alla risoluzione giusta. Come molti possessori di iBook sapranno, Apple ha inibito nel firmware dell’iBook l’estensione desktop e quindi, nonostante la scheda video possa farlo, nativamente si può usare solo la duplicazione del monitor (con risoluzione pari a quella del monitor interno).

Fino all’altro ieri ho utilizzato Screen Spanning Doctor per superare questo odioso ostacolo, che ha la caratteristica di essere un “hack” facilmente reversibile resettando la PRAM (avvio con command alt p r). Così stamattina lancio lo script, abilito sia lo span che il clamshell mode (anche se non uso) e riavvio. Attacco il monitor e tutto sembra funzionarealla grande, finché…
…finché non decido di ascoltare un po’ di musica e dalle casse non esce alcun suono. Alzo il volume, ma compare un simbolo di divieto! Preoccupato vado in Preferenze di Sistema>Suono e leggo “nessun dispositivo audio rilevato” sia per l’ingresso sia per l’uscita. Eppure ieri funzionava tutto!! Faccio due più due, riavvio resettando la PRAM, e tutto torna a funzionare tranne, ovviamente, Screen Spanning Doctor.Appena avrò tempo farò altre prove, magari non attivando la modalità clamshel, ma a quanto ne so per ora, Screen Spanning Doctor con Mac OS X 10.5.2sull’iBook G4 con la ATI 9550 fa più casini del dovuto. Fatemi sapere se voi avete gli stessi problemi oppure no, e su che macchine!Non penso aggiorneranno il simpatico script, dato che questo è fermo dal 2005, che interessa solo i Mac PPC e che l’aggiornamento interesserebbe solo quelli che hanno un Mac PPC e hanno Leopard 10.5.2.

UPDATE: abilitando solo lo spanning e non il clamshell, tutto funziona. Mi sono accorto che se resetto la pram il sistema perde l’opzione “Richiedi password per uscire dallo stop e dal salva schermo” nonostante sia correttamente impostata. Riavviando da capo tutto ritorna a posto. Boh, cos’hanno fatto con questo aggiornamento lo sanno solo loro!

’nuff said

  • TuxBastard

    Hmm.. io quando ho installato Leopard, non ho mai provato a installare ScreenSpanningDoctor… eppure l’altro giorno attaccando l’ibook alla tv in sala ha funzionato tutto perfettamente.. risoluzione video e audio perfetti… che sia rimasto funzionante da quando l’ho installato da Tiger? Mi sembra strano… non può essere che con Leopard hanno tolto la limitazione per gli iBook? Come del resto hanno fatto con Front Row il quale adesso è disponibile su tutti i Mac!

  • Jeby

    finché non resetti la PRAM SSD riamne dov’è, anche se riavvii o aggiorni. Sul 10.5 e sul 10.5.1 mi funzioanava tutto con SSD, ora mi fa casini, ma forse è solo la clamshell mode. Comunque NO, non è abilitata la scrivania estesa con leopard sul mio iBook.

  • steppia

    Sì comunque il S.O. non c’entra, credo: io ho fatto un installazione pulita di tiger e una di leopard ultimamente e il mio ibook (radeon 9200-32MB VRAM) supporta ancora l’estensione del desktop senza problemi.Ho usato SSD l’ultima volta o sul panther o sulla prima installazione di tiger…

  • steppia

    il problema comunque è ben più ampio: http://www.fogliata.net/2008/02/16/leopard-monitor/

  • M@t

    Penso sia un bug…io con powerbook g4 ho avuto il tuo stesso problema con l’audio, però senza eseguire alcuno script o programma particolare, mi si è presentato dopo un paio di giorni di utilizzo del mac con il nuovo aggiornamento, ho riavviato semplicemente (senza resettare la pram) ed è sparito e non si è più ripresentato…

  • Luigi Cubeddu

    Tale problema si verifica saltuariamente con l’architettura G4, ma non è imputabile solamente al processore: mi pare di aver capito che c’entri l’hardware audio, piuttosto obsoleto rispetto al nuovo sistema operativo. L’audio, in pratica, mi è parso di capire, non viene attivato al riavvio (spesso Leopard fa anche scomparire l’icona dell’altoparlante dalla barra) e ciò deriva da una incompatibilità che sorge tra il SO che deve andare ad interpretare il Core Audio. Nei diversi test da me effettuati su un PowerBook g4 17″ (2gb ram) si presentava spesso dopo un uso scorretto di applicazioni musicali di dubbia provenienza o dopo l’aggiornamento di alcuni componenti di QT; anche l’uso troppo continuo di Onyx o iTool potrebbero far accadere tale problema, ma ripeto: è solo momentaneo (basta un riavvio). Su sistemi Intel ciò non accade, per via dell’architettura di sistema; pienamente compatibile con nuovo SO.